Page 1 of 1

IP adress in WAG54G gateway

Posted: Sat Sep 11, 2004 4:23 pm
by Bas
Hello everyone,

I'm a new member and want something to ask all of you.

I'm working with an WAG54G gateway and this is my problem!

I'm having an connection but it is an automaticly assigned to an ip adress.
That is good only the next thing I'm not happy about I'm getting an Ip adress that starts with 169.254 I'm guessing this is an microsoft standard IP adress.

Does anyone else have this problem because when I'm putting an static IP adress into my network connetion I'm not getting on the internet!

Anyone have an sugestion?

please help me It's is very frustrating?! :twisted:

Posted: Sun Sep 12, 2004 10:54 am
by david
Hey Bas,

Is it your WAG54G that gets assigned the 169.254.x.x IP or some other device you have connected to the WAG via cable/wifi?

If it's the first case, have a look here where there is more on the same subject.

If it's the latter, it means that the device was able to get an IP from the built-in DHCP server in the WAG54G. This could be one of many reasons depending on the connection medium (wifi/cable), device type (laptop, PDA) and more.

Let us know more details!

Posted: Tue Sep 14, 2004 8:54 am
by Bas
Well al my pc's are getting an adress but now it is different again now only my laptop is getting this wrong IP adres assigned?
It's very strange I wil look at the other topic maybe this will help me.?

I found an article on the internet about SP 2 from windows XP that has an problem with wireless networks and so?

Thanks for the help I hope it will work.

If it doesn't i hope someone can help me?

Posted: Tue Sep 14, 2004 9:23 am
by david
Have you turned OFF the built in Windows fire wall (Internet Connection Firewall)?

Start / Connections / Show all connections / Local area connection (or Wireless Connection) / Advanced / UNCHECK Internet Connection Firewall.

If the firewall is turned on, it will block connections from the router to your computer. The router is now your fire wall.

With SP2 I believe the Internet Connection Firewall is ON by default making some users loose their connection.

Posted: Wed Sep 15, 2004 5:45 am
by Bas

Maybe that is it when I had a good connection with a good IP range not that Windows IP range I could get on the network and other PC but not on the internet .
I haven't checked the thing you just said? I will try it and let you know if it helped!

thanks :)

Posted: Wed Sep 15, 2004 2:42 pm
by Bas

That wasn't it! :cry:
I still have the problem that my laptop gets an IP range of
How should I deal with this problem becasue other PC in the network with UTP cable have connection and have internet. Why is my laptop not respondig wel? is it really SP 2 that bugs me?

Posted: Wed Sep 15, 2004 4:36 pm
by david
Sounds like a "simple" WiFi set-up problem. I have added you to my MSN, let's discuss this online? :-)

Posted: Thu Sep 16, 2004 7:06 am
by Bas
alright I will be home later this evening and I will check if you are online.
Maybe I have kicked you yesterday but try it again please
I'm sorry if I kicked you I get a lot of such requests so I don't trust anyone sorry.

I'm very thankfull you would make time to help me with my problem! :D

Posted: Wed Sep 29, 2004 4:40 pm
by peterk
I have exactly the same problem, on two different wireless clients with different WiFi cards, one running Win98SE and one running Win2K. The only common element is the WAG54G.

I get the same IP address which, I think, is the default IP address windows configures when it can't see the DHCP server.

I have emailed Linksys tech support ... I await the response!!

If you find an answer then please let me know. Thanks in advance :?

Posted: Tue Oct 19, 2004 9:04 pm
by David_C
if you set a static IP addres you need to set a DNS addressa also this can be found on the WAG54 status tab - look for primary DNS server.

It seems to be assumed people know this as I had this problem as well and ha problems sorting it - search engines were my route side stepping the support

Linksys support FAQ is at ... =search_nl

Posted: Wed Oct 20, 2004 9:33 am
by david
One undocumented feature seems to be a built in DNS proxy on the WAG54G.

If I set up a computer with static IP, I set both the default gateway and DNS IP to and it works... but since I am paranoid I usually switch later to the DNS IPs given to me by my ISP.

Posted: Sat Apr 09, 2005 3:11 pm
by Kris
Hey I have had some problems with this and this is how I solved it.

Router is

Enable DHCP

then when assigning ip's to your computers remember not to give your computer an IP that resides within the DHCP range usually to so anything from to are available to be assigned to your computer. You will need to find out from your ISP what your DNS servers are called, I found mine when I logged on to the advanced settings within my isp's web page, but you can do it this way to.

Goto start/run the type cmd, then type nslookup this will or should give you your ISP's dns servers, there should be 2, 1 primary and 1 secondry if this si not the case email your isp for the details they will be quite happy to help you.

When you enter the dns server info where you were assigning the static ip's for your computers behind your router. Now here is the cool bit, goto advanced/dns on that box your adjusting and enter the 3rd dns server as as a back up if your isp dns servers fail.

I have done this for 5 computers on my home network, 2 of them are wireless laptops and they work absoloutly fine.

If anyone wants screen shots or a more in depth explanation I will be quite happy to provide this, right now my girlfriend is shouting at me that I should be ready and walking out the door :)