Page 1 of 1

VPN Fixed - Now Wireless is broken!

Posted: Tue Jun 15, 2004 9:27 am
by duncane
AFter months of frustration with the WAG54G, linksys finaly released new firmware (1.02.2) which fixes the PPTP VPN issues, available here: ... =32&coid=6

With this installed, PPTP VPNs now work a treat, and I was happy...

However a day later I'm most definately not! Sure the VPN problem is fixed, but now my centrino laptop won't stay connected for more than about 1 hour. The laptop still 'sees' the network when I hit the refresh button in the wireless network connections dialog, but simply won't re-connect. The only resolution is to reboot the WAG54G, rebooting the laptop makes no difference!

Anyone else having similar problems?

Posted: Tue Jun 15, 2004 4:24 pm
by Guest
Dont have this problem. The difference might be encryption... because of some old crappy 802.11b cards on the WLAN I'm neither running WEP or WPA.. just MAC filtering. Try it out without encrpytion and see if it makes a difference for you.

Posted: Thu Jun 17, 2004 7:09 pm
by duncane
Nope, I've tried it with all the encryption (in fact *all* wireless security) disabled - still have the same problem... I've had to downgrade to 1.01.7 just to make the WLAN useable... of course now PPTP VPN is broken again.

Posted: Fri Jun 18, 2004 9:13 am
by david
Duncan, I just remembered.

When my wife got her new centrino (g) laptop the connection was like a yoyo (lasted maximum 5 minutes).

I was very disappointed but there was an updated driver for the centrino that fixed it. Not sure if I got it from Intel or Microsoft.

I have noticed that all the problems people are having with their WiFi is not always the WAGs fault. Sometimes it is due to other hardware on the network.

I have never had any VPN problems, always connect perfectly to office via Cisco VPN client. Have not had any problems with port forwarding, range port forwarding nor DMZ.

The problem I have had is a d-link device that keeps disconnecting once a day and some DHCP problems with a b device (iPaq).

But having read all the reported problems with the new firmware, I am not even going to try it.

Posted: Fri Jun 18, 2004 5:05 pm
by david
Looks like Linksys have gone back one version, the latest firmware posted is now 1.02.1 from May 18th: ... =32&coid=6

They also recommend to reset router to factory defaults after the upgrade if you are experiencing WiFi connection problems. Did you try that?