Page 1 of 2


Posted: Sun Feb 29, 2004 9:37 pm
by Guest
I am trying to make a vpn connection to my company server. Using my old Zoom x3 modem there is no problem. With the wag54g i get error 'Error 732: Your computer and the remote computer could not agree pn PPP control protocols'. I have set port triggering 1723 as detailed in 'KB10934339'. Still no luck.
Any ideas?


Posted: Sun Feb 29, 2004 9:39 pm
by Guest
using PPtP passthrough with WIN2K as client behind WAG54G

Posted: Mon Mar 01, 2004 9:31 am
by david
Hey Guest,

I have not tried the VPN functionality (yet) so cannot help out...

No wireless access

Posted: Thu Mar 04, 2004 4:42 pm
by Guest

a quick question - can anyone tell me if on the wireless status section of the WAG54G they have a MAC address? A simple yes or no - I don't want your address!! :shock:

Reason I ask is that I got my WAG54G on Monday - configured ADSL no problems, upgraded firmware, configured wireless (normal stuff - changed SSID, enable encryption) via the ethernet port - but wireless is not working. I don't see the network at all and I have noticed that there is no MAC address showing - which I think is strange. Yes I have tried resetting everything to factory settings.

I will be configuring a VPN to my office as soon as I get it all working - so may be able to help previous post.

Thanks for any help,


Posted: Fri Mar 05, 2004 6:53 am
by david
The Status / Wireless should definitely show the MAC address of the WAG54G. Try calling UK support, they were very helpful (alas reading from a manual) when I finally got through.

Below is what my status shows:

Wireless Firmware Version:
MAC Address: 00-0C-41-**-**-**
Status: Enabled
Mode: 802.11g
Channel: 6
SSID: **********
Encryption: Disabled

I am using WPA-PSK so not sure why the "encryption" shows as disabled.

Posted: Tue Mar 09, 2004 12:52 pm
by Guest
I have been trying to get VPN to work on my WAG54G for two weeks now. Still no luck, only way I can find (and it seems to be the only way other users have found) is to disable the firewall for the time you want to use the VPN. I have tried port forwarding 1723, 1701, 500 to the correct IP address, port triggering as in KB10934339, enabling /disabling PPtP and or IPsec passthrough etc.. Still no joy. If any one out there does find another way, I'd love to hear it!

Posted: Wed Mar 10, 2004 8:48 pm
by Guest
I too have the same problem with VPN. Only works with the firewall disabled. This is definitely a bug in the firmware.

Posted: Thu Mar 11, 2004 9:40 am
by david
Have you tried calling Linksys support? They were quick to answer last time I called and did have an answer (despite me being able to hear the support person flipping pages in some book).

Having to turn of the firewall to make VPN work seems very poor indeed. I was equally disappointed that to make the router work with static public IPs, one has to disable the DHCP. Not intuitive at all.

re: wireless MAC Address

Posted: Mon Mar 15, 2004 5:03 pm
by Guest
Cheers for your help!

I have since managed to get my wireless connectivity going - although having major problems with thr NIC in my PC. The Linksys games adpator I use for my PS2 works great but the Linksys PCI wireless NIC I got is very flakey - low rates and often loosing connectivity. The PC is closer to the wireless router then the PS2!
Currently using ethernet.

I managed to get wireless working after checking a KB article about something else. It mentioned that once a update is done to a device (firmware or options) to power off for at least 30 seconds. This I did and up she came all OK!

Next VPN!!

Posted: Mon Mar 15, 2004 5:56 pm
by Guest
I'm having the same problem with the Linksys WAG54G and VPN.

Have Sent a request to Linksys via e-mail. If I hear back I will let u Know.

John, UK.

Posted: Wed Mar 24, 2004 9:57 am
by david
Here is a good resource for VPN problems: ... qid/346178

Posted: Fri Apr 02, 2004 7:30 pm
by Guest
Has anyone got anywhere with this? I'm having the same problem and its driving me nuts!

Posted: Tue Apr 06, 2004 11:26 am
by Guest
Anonymous wrote:Has anyone got anywhere with this? I'm having the same problem and its driving me nuts!
Have had a message back from Linksys about the VPN problem and guess what!

We have had our escallation team test this but they were unable to reproduce the errors you are having. They were using firmware version 1.01.5, which is available on the website

If you have further questions, please contact us at 08707 393939 or send us an email at [email protected] so that we may further assist you.

Technical Support

[email protected]
Linksys - A Division of Cisco Systems, Inc.

Same problem with firmware revision 1.01.5

Posted: Mon Apr 12, 2004 11:20 am
by VPNHell
I have tried this revision of the firmware and I am also completely unable to connect to VPN with the firewall enabled. Exactly the same problem. Took Linksys 1 month to get back to my support request with questions that I had already answered in the original mail.

I am very unimpressed by Linksys currently... :evil:

Guest, did you get VPN working through the firewall? If so please put me out of my misery.

Posted: Mon Apr 12, 2004 8:53 pm
by Guest
Failed to get VPN working. I am getting a refund on my box and getting a Netgear 834G - I know a few people with this box and it works a treat.

I got my box from broadband buyer - their support has been excellent. They even sent me some updated firmware (1.01.7). Unfortunately it didn't fix the problem. Direct support through Linksys has been absolutely crap IMHO.

There is some good info on the Broadband buyer website (acknowledging VPN problems). Read the customer reviews for the WAG54G.

Thumbs up to Broadband Buyer!!
Thumbs down to Linksys!!