The Story of David Kaspar Forum Index The Story of David Kaspar
Electronic discussions
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

laser dim, disc won't spin up.

 
Post new topic   Reply to topic    The Story of David Kaspar Forum Index -> How to fix your PS2
View previous topic :: View next topic  
Author Message
tat2zz



Joined: 28 Feb 2007
Posts: 8

PostPosted: Wed Feb 28, 2007 7:50 pm    Post subject: laser dim, disc won't spin up. Reply with quote

Hello all, I have a ps2, version 50001. When I got it, it was having dre problems. I have repaired many ps2's but this time I don't have a clue. Anyway, I took the console apart, and took the top off of the drive. I placed a disc on the spindle, and turned the power on. It spun for a second or two, then stopped. The laser needed cleaned, which I did. I put it back in, and hooked everything back up properly, and tried again. Nothing. Or to rephrase, the laser is very dimly lit for a split second, but the disc won't spin at all. I have checked the laser, it seems fine, the ribbon cables all have good continuity. I have read about many problems with the cd drive
chip, the la6508 chip going bad. So, I replaced it very carefully, and did the romeo 5v mod thinking the chip may have burned up with too much power to it. It now has the 5v instead of the 12v. Still nothing. I have checked the 6508 pins with a multimeter making sure no solder crossed the pins, and they are all fine as well. Still, thelaser blinks VERY dim for a second, but the disc doesn't even try to spin. Could you please tell me what to check? I am at a loss here. Any help would be greatly appreciated.
The ps2 is not mod chipped, the only mod done was the power mod. Somebody please give me an idea of where to start checking?
Thanks, Mike. Sad
Back to top
View user's profile Send private message
david
Site Admin


Joined: 28 Jan 2004
Posts: 164

PostPosted: Thu Mar 01, 2007 3:32 pm    Post subject: Reply with quote

Obviously you have more detailed knowledge about the PS2 than me. All I did was to re-align the cd drive after a fall Smile

Since you have replaced the la6508 chip and it didn't help. Could it be the control circuit of he chip that may be broken?

Sorry, maybe khat17 has a word to add....


Last edited by david on Tue Mar 06, 2007 9:46 am; edited 1 time in total
Back to top
View user's profile Send private message
khat17



Joined: 11 Nov 2006
Posts: 79

PostPosted: Mon Mar 05, 2007 2:46 am    Post subject: Reply with quote

I like what you've done so far. Obviously you have a lot of experience in the electrionics department - I passed electronics but I didn't really like it.......anyways. I have never seen that kind of problem with a PS2, but I have seen it on the PS1. With the PS1 it usually is a lens adjustment problem. The tuning screws can be over-adjusted, and doing so will damage them - meaning you will need a new lens. The ribbon cable for the lens could be damaged, maybe burnt on one of the leads. You were saying some of the chips on the board were damaged and that you made the changes flawlessly, but, in your current case the best suggestion I can think of is with the use of a second PS2 for testing purposes. Swap around the lenses and see what happens. It doesn't even have to be a fully working lens - as you know some may be bad and read only one type of disk or another - you just need it for testing purposes. If you have no other PS2 that may be used for testing then post back and we can run over some diagrams and such and see if we can get a better fix on where the problem may be. Also, I hope you used a good soldering iron to ensure no damage to the board...........Multi-Layered boards are a bad thing to have damage done to.

PeAcE.
Back to top
View user's profile Send private message
tat2zz



Joined: 28 Feb 2007
Posts: 8

PostPosted: Mon Mar 05, 2007 5:44 pm    Post subject: thanks for replying Reply with quote

Hi, and thanks for replying. I tried the laser from the 50001 in a 39001. It lit up a lot brighter, but wouldn't read. The lens coils are perfect. Both reading in at 4.8 to 5.0 for ohms, so the coils are fine. I am waiting on a new laser to arrive in the mail, and I will try it to see if it takes care of the problem. I am self taught on electronics, and have a fair amount of knowledge in that area. I have rebuilt several arcade game boards, and build quite a few computers too. Anyway, the only chip on the board I suspected was the la-6508 chip. I carefully removed the old one, and tinned the new chip legs. I placed it on the pads from the old one, and touched each leg for about a second and a half. Just enough to make the solder melt and attach the chip. I let it cool off between each soldering round, to insure little or no heat damage. So, I am pretty confident that the chip replacement went fine. I checked the disc drive motor ribbon cable with my multimeter, and it checks fine. I tried a drive motor from a junked out 39001 I have for parts. No changes there. So, my main question would be this: What component makes the disc drive spin up? I have read the la-6508 is the drive chip. Since I replaced it, the laser is still very dim, and the drive still dosent try to spin up. Hmmmm.......... I'm at a loss. I joined another forum recently, and the guy over there said that the laser being bad will cause the drive to not spin up too. I just don't know. 1 side note here, I know there are many small block fuses on the board. However, I don't know if there are any between the 6508 chip and the drive that may be blown. So, I don't know where to check there. Any help is greatly appreciated. Thanks again, Mike.
Back to top
View user's profile Send private message
tat2zz



Joined: 28 Feb 2007
Posts: 8

PostPosted: Tue Mar 06, 2007 6:19 am    Post subject: recieved new laser Reply with quote

Okay, I got the new laser in the mail today. I put it in, and nothing changed. Laser still dim, and no disc spin at all. So, it must be something on the board itself. Any ideas on where to start checking? Please let me know. Thanks, Mike.
Back to top
View user's profile Send private message
tat2zz



Joined: 28 Feb 2007
Posts: 8

PostPosted: Wed Mar 07, 2007 4:29 am    Post subject: possible problem found Reply with quote

Khat, hi, hope you receive this soon. I believe I may have found the problem, but I don't know. My motherboard is a gh026. The only microfuse on the board that has no continuity through it is at spot ps13. A very small grey colored block soldered on both ends. However, there is a small mystery with it. This "fuse" doesn't seem to connect to anything. It connects 2 traces. On one end, it goes to the disc motor spindle ribbon cable trace area, via a few other components. I can see that it does make a path there. However, the other end of the fuse leads seemingly to a dead end. It leads to 4 holes going through the board, but they are seperated from any other VISIBLE connections. Here's the kicker, do you know if the board being sandwiched may hide the continuing path for this fuse? If so, then this is quite probably the culprit.
Back to top
View user's profile Send private message
tat2zz



Joined: 28 Feb 2007
Posts: 8

PostPosted: Wed Mar 07, 2007 11:13 pm    Post subject: spindle has spin again Reply with quote

I changed out ps13, and the drive spins up now. I was lied to about the laser I bought being new, the focusing cap has q-tip material around it, and the pots on the bottom have no reading at all. Maybe this is why the laser is dim? Anyway, I will get another laser and try it to see if I am back in business.
Back to top
View user's profile Send private message
khat17



Joined: 11 Nov 2006
Posts: 79

PostPosted: Mon Apr 09, 2007 3:33 pm    Post subject: Reply with quote

So very sorry for the looong no reply. I didn't check back the forum in a while because of no internet - lightning knocked out my DSL modem. That and work stopped me for a bit. Good to see you're back in business. If you have a digital camera could you post some pics of where you did your work on the board? Thanks in advance.

PeAcE.
Back to top
View user's profile Send private message
david
Site Admin


Joined: 28 Jan 2004
Posts: 164

PostPosted: Wed Apr 11, 2007 10:12 am    Post subject: Reply with quote

Pics would be nice. Let me know if you have any problems posting them in the forum and I'll fix it.
Back to top
View user's profile Send private message
tat2zz



Joined: 28 Feb 2007
Posts: 8

PostPosted: Wed Apr 11, 2007 3:56 pm    Post subject: Hey, Reply with quote

No problem. give me a few days, and I will get the console taken back apart and some pics poosted. Thanks for the interest. Take care all, Mike.
Back to top
View user's profile Send private message
tat2zz



Joined: 28 Feb 2007
Posts: 8

PostPosted: Wed Apr 18, 2007 12:27 am    Post subject: Hey Reply with quote

Got a problem, I have the pics to post, but am unsure how to. I read you need to put them on a public forum. I have never gone this route to post pics before. I am used to just uploading them. Can you give me a rundown on where to post, and how to link it? Never done it that way before. If needed, I can email them to one of you, and you can link them with some of your own pics? Please let me know, and thanks again, Mike.
Back to top
View user's profile Send private message
khat17



Joined: 11 Nov 2006
Posts: 79

PostPosted: Fri Apr 27, 2007 11:00 pm    Post subject: Reply with quote

David's taking a little long to respond, gonna up the pics to somewhere and then link the urls to them. Also gonna get back a digital camera (a friend messed up mine) and post some decent pics on what to do and how to do it.

The images posted are raw images, unedited and will be cleaned up and done over at a later date. These are done assuming you know how to pull down your PS2 and get your board out.

Main Board


LA 6508 Chip


LA 6508 Chip - Closeup


That is the chip that TAT2ZZ changed. From that angle it's at the bottom right and is right beside the connection on the board for the lens.

PeAcE
Back to top
View user's profile Send private message
david
Site Admin


Joined: 28 Jan 2004
Posts: 164

PostPosted: Tue May 01, 2007 3:12 pm    Post subject: Reply with quote

Excellent, photobucket seems to have worked. Thanks for that.
Back to top
View user's profile Send private message
khat17



Joined: 11 Nov 2006
Posts: 79

PostPosted: Wed May 28, 2008 12:55 am    Post subject: Reply with quote

(Correct me on the info provided if I'm wrong)

I would recommend to anyone that has a PS2 to do the ROMEO MOD whether or not you have a mod-chip installed. This will save on the lens. Basically, the lens uses up to a 12V power line and this voltage may spike when reading disks that are badly scratched - or in the case of modded consoles, disks burned on poor media. The ROMEO MOD saves the lens by connecting it to a lower voltage connector (5V instead of 12V) so that the lens will survive if the voltage spikes. And yes, it works with the 5V instead of the 12V.

Just do a GOOGLE search for ROMEO MOD to find the one specific to your console, as the solder points differ from version to version.

PeAcE.
Back to top
View user's profile Send private message
Display posts from previous:   

Post new topic   Reply to topic    The Story of David Kaspar Forum Index -> How to fix your PS2 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group